Faceborg was developed using javascript technology too. Please enable javascript to get the website running properly.



 
20231103 18:57


I finally *melt* my OpenBSD system targeting sticks of 32gb.

0. I prepared a note with the new stick layout I would like to realize.
1. copymachine: I copied my 16gb stick into my target stick.
2. fdisk: I growed size of the OpenBSD partition to 59000000 sectors.
3. disklabel: I incrised the OpenBSD boundaries to 59000000 sectors.
4. disklabel: I erased all the existing partitions.
5. disklabel: I created the new stick layout as from the note above.
6. I *newfs* all the data partitions.
7. I repeated for every partition needing to be data populated:

cd /tmp
umount /mnt/oldkey
umount /mnt/newkey
mount -t ffs /dev/sd1a /mnt/oldkey
mount -t ffs /dev/sd2a /mnt/newkey
cd /mnt/oldkey
pax -rw -pe . /mnt/newkey/

8. installboot: I launched it in this way to prevent any boot problem:

installboot -v -r /mnt/neykey sd2 /usr/mdec/biosboot /usr/mdec/boot

9. I updated /etc/fstab accordingly to new layout of the new stick
a. I rebooted the pc in the new stick to test the resulting system.
b. I recovered all the immutable flags on the pertaining files.

I hope this is helpful to someone.
 
20231101 10:28


OpenBSD Fundraising campaign 2023

https://typeme.in/l/obf2023
 
20231101 10:26


Double check your usb stack for uknown devices could be eventually easy:

man usbdevs
usbdevs -v could be more verbose too.

Indeed, in my case addr 04 is a unknown device to me.

wiz$ usbdevs -v -a 04

addr 04: mine:---- ?????\^A??, ?????\^A??
full speed, self powered, config 1, rev 0.01, iSerial ?????\^A??
driver: ugen0

Then:

wiz# dmesg

[..]
ugen0 at uhub0 port 4 "?????\^A?? ?????\^A??" rev 1.10/0.01 addr 4

I see this unknown device is the only one using ugen, the generic driver for devices
not provisioned with recognized system drivers, etc.


 
20231101 10:25


For who is concerned about it:

32gb sticks are quitely exiting the market, hurry up!
 
20231026 21:24


How-to disable ucc driver.

ucc driver allows you to have support for consumer keyboards like for multimedia keys and so forth. To avoid pseudo keyboard devices get initialized using ucc driver do the following:

1) open /etc/bsd.re-config;
2) insert in it the following:

disable ucc

3) save it and reboot a two times.

Thanks to Crystal and Ze.
 
20231021 00:21


Nice shortcut to know:

Ctrl + Arrow Left / Arrow Right

to move the cursor fast between words instead of characters.
 
20231016 08:03


OpenBSD 7.4 released.

 
20231013 00:41


Feature request.

I would probably be happy if under securelevel=2

rcctl -f start sshd

will not be possible anymore.
 
20231010 00:45


securelevel 2 and readonly disk.

Given securelevel = 2 low level disk commands like fdisk, disklabel and newfs can't run.

Indeed the disklabel appears to them kind of "readonly" as from the man.
 
20231010 00:33


How-to (not) backup from a remote file source.

Apparently it doesn't exist yet a good software solution that solves the quiz in a decent way.

My own solution is to do the backup on my online server by Duplicity and download the delta file to my local.
And I'm able to make everything happening within a good data transfer and time fashion.

Indeed, it appears that I'm not the only one doing such thing..

Thanks everyone for the suggestions!
 
20231005 04:16


How to chroot correctly users by ssh\ftp:

In /etc/sshd_config:

(when myftpuser is the name of your ftp user)

Match User myftpuser
ChrootDirectory /var/ftp
ForceCommand internal-sftp

Then a little attention to the permissions on the user's home folder:

First:
usermod -d /do/upload myftpuser

Second:
sudo mkdir -p /var/ftp
sudo mkdir -p /var/ftp/do
sudo mkdir -p /var/ftp/do/upload

In special way:
sudo chown -R root:myftpuser /var/ftp/do
sudo chown -R myftpuser:myftpuser /var/ftp/do/upload

Thanks go to Peter and Stu for all the tips.
 
20231005 04:04


Just want to point out how the Orico 3559U3 External Enclosure with 5 HD bays 2.5"/3.5" compatible and hotplugable in OpenBSD too is really saving my days to store my backups:

https://typeme.in/l/O3559U3


 
20230929 19:55


A little old but useful to know:

wiz# sysctl | grep kern.video.record
kern.video.record=0
wiz# sysctl | grep kern.audio.record
kern.audio.record=0

"Analog to the the kern.audio.record sysctl parameter for audio(4)
devices, introduced kern.video.record for video(4) devices. By default
kern.video.record will be set to zero."

More info:

https://typeme.in/l/77c7c7c/
 
20230929 19:18


Just found the interesting paper "Towards running a Wayland Compositor on OpenBSD" from EuroBSDCon 2023:

https://typeme.in/l/249a035
 
20230929 15:58


I just came to know the net utility nc (or netcat) by which you can do chats, file transfers, port probs etc.

Open the man (or mangl) and point to nc.



   
  
Hash Me!
 
  A 5 Mode project and WYSIWYG system. Some rights reserved.